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Abstract-Now a days, numerous uses of artificial intelligence are found in the healthcare industry. Building advanced 
devices that can detect diseases and identify cancer cells uses AI applications. In order to ensure early diagnosis, artificial 
intelligence can assist in analyzing chronic illnesses with lab and other medical data. In this study, an IoT based home 
management and monitoring system with cheap cost and flexibility is presented. Using the Facebook Messenger app, 
users may access and remotely operate gadgets and appliances using smart phones. In contrast to prior systems, the 
proposed system provides a communication protocol to monitor and control the home appliences with the Messenger app 
in smart phones.The intelligent networking of common place devices like smart phones, Internet TVs, sensors, and 
actuators to the Internet is known as the Internet of Things (IoTs). New forms of communication between objects and 
humans as well as between things and other things are made possible by this.Now that everyone, from anywhere, can 
have connectivity for anything, In this project, the Facebook Messenger and the ESP8266-12E NodeMCU are used to 
operate electrical home appliances. Chatfuel is the tool used to build Facebook AI chatbots. IFTTT and Adafruit IO are 
also used by the project for back-end assistance. 
 
Keywords-TheChat box, The House Assistant, The Human-Robot Interaction Module(HRIM)  
 

I. INTRODUCTION 
House automation, sometimes known as "smart homes," is the integration of technology to the home environment to 
offer its residents ease, comfort, security, and energy efficiency. Home automation research and implementation are 
becoming more and more popular as a result of the Internet of Things. Different wireless technologies, including 
Bluetooth, WI-Fi, RFID, and cellular networks, have been used to embed different levels of intelligence in the home. The 
gadgets are physically linked to a Bluetooth sub-controller, which the smart phone may access and control using built-in 
Bluetooth connectivity.[1] Home gateways have also been used by researchers to try and enable network compatibility 
and remote access for household appliances and gadgets.In this project, the Facebook Messenger and the ESP8266-12E 
NodeMCU are used to operate electrical home appliances. Chatfuel is the tool used to build Facebook AI chatbots. 
IFTTT and Adafruit IO are also used by the project for back-end assistance. It's a terrific project for fusing AI with the 
IoT. Separately created IoT and chatbots are combined to create the final chatbot. By using this AI based chatbot we can 
communicate by messaging in any language in the world, and it can operate any appliances.We can use our smart phones 
to operate smart home appliances like lights, switches and fans. 
 

II. MATERIALS AND METHODS 
This project is made using the following integrations of components and softwares. The hardware circuit diagram is 
shown in the Fig 1.In this project, two types of integration takes place which are 

• Hardware Integration 
• Software Integration 

 
Hardware Setup 
This project makes use of Lolin's NodeMCU ESP8266 - 12E. NodeMCU is connected with the 1 channel 5V relay 
module. The Relay module acts as a switch and it is connected with the phase of the current and the neutral is directly 
given to the appliences. [2] Whenthe NodeMCU is connected to the Wi-Fi and we send a message through the chatbot 
created with Facebook Messenger and it sends the output to IFTTT through JSON API URL which has been Integrated 
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in Chatfuel and then the value passes to NodeMCU through Adafruit IO and then the NodeMCU sends a signal to the 
relay and hereby the appliance is controlled using the chatbot. The Hardware experimental setup is shown in Fig 2. 

 
 

Fig 1.Circuit Diagram. 
 

 
 

Fig 2.Experimental Setup. 
 

Components 
NodeMCU 
NodeMCU is an open-source firmware and development board that is based on the ESP8266 Wi-Fi module. It allows 
developers to build Internet of Things (IoT) applications with the Lua scripting language. The NodeMCU development 
board features an ESP8266 module, which provides integrated Wi-Fi connectivity, as well as GPIO pins for connecting 
sensors, actuators, and other peripherals. [3-9] The board also has an onboard USB-to-serial converter, which makes it 
easy to program and communicate with the device. NodeMCU can be programmed using the Lua scripting language, 
which is easy to learn and widely used in the IoT community. Lua scripts can be uploaded to the device using a USB 
cable and a programming tool such as the NodeMCU Flasher. Node MCU can be used to build a wide variety of IoT 
applications, including home automation systems, environmental monitoring devices, and more. Its open-source 
firmware and development board make it a popular choice for hobbyists and professional developers alike. The 
NodeMCU is shown in the Fig 3. 
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Fig 3. NodeMCU. 
 

Relay Module 
A 1-channel 5V relay module is an electronic device that allows you to control a high-voltage circuit using a low-voltage 
signal. The relay module typically consists of a relay, a control circuit, and a set of screw terminals for connecting to the 
high-voltage circuit. The relay module is shown in the Fig 4. 
 

.  
 

Fig 4. Relay Module. 
 

The 5V in the name refers to the voltage required to power the control circuit. This voltage can typically be supplied by a 
microcontroller or other low-voltage device. The 1-channel in the name indicates that the module has a single relay that 
can be controlled by the input signal.When the control signal is applied, the relay switches its contacts from one position 
to another, allowing or blocking the flow of current through the high-voltage circuit. This can be used in a wide range of 
applications, including home automation, industrial control, and robotics.[10-15] 
 
Jumper Cables 

 
 

Fig 5. Jumper Cables. 
 

Jumper cables, also known as jumper wires, are used to connect different parts of a circuit board together. They can be 
used to create connections between different pins on a microcontroller, connect sensors or other devices to a circuit 
board, or to connect components on a breadboard. Jumper cables come in various lengths, colors, and sizes. They are 
typically made from copper wire and have a male pin on one end and a female pin on the other end. The male pin is 
inserted into a hole on the circuit board while the female pin is used to connect to another component. Jumper cables can 
be purchased in pre-made sets or you can make your own using wire and male/female pins. When making your own 
jumper cables, it's important to use the appropriate gauge wire for the application and ensure that the pins are securely 
attached to the wire. The jumper cables are shown in the Fig 5. 

 
Electrical Components 
The Electrical components used are Bulbs, Bulb Holders, Switches, Plugs, Plug Points. These are the basic components 
we use in our day to dayflies. The electrical components are shown in the Fig 6. 
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Fig 6. Electrical Components. 
 

III. SOFTWARE INTEGRATION 
Messenger 
Messenger is a facebook messaging platform. Facebook Messenger is MQTT-based. MQTT is specifically made to use 
bandwidth and batteries sparingly for tasks like transmitting telemetry data to and from space probes. My opinion of the 
MQTT protocol is that it is really fundamental, and Facebook chose it because it makes it simple for them to construct 
and continue customising their protocol. [16-20] We really want a Virtual human to visit with. For this, we will make a 
Facebook Page. To make a Facebook Page. Fill your Page name and Class you wish, you could in fact add a Profile 
Picture and Cover Page to it. You should likewise conceal your Page name and do settings so your page isn't accessible 
openly. 
 
Chatfuel Setup 
For the chatbot to effectively understand and respond to user requests, users can set the rules of the discussion via the 
Chatfuel dashboard. An adaptable chatbot that can serve as an event assistant, customer service adviser, or sports team 
informant can be created by users using Chatfuel. 

Using Chatfuel, anyone without any programming experience may develop their own Facebook Messenger bot. It 
offers capabilities like uploading content cards and instantly sharing it with your followers, collecting information inside 
Messenger chats with forms, and allowing users to interact with your bot by pressing buttons. People prefer speaking 
over choosing selections from a chatbot because it is more comfortable[7]. Additionally, it offers AI technology for 
scripting interactive discussions and use AI to recognise user responses and deliver the right response.From here, go to 
Chatfuel Platform , then click "Create from Template" and "Blank Bot" on the Dashboard.. You can now begin using the 
AI component of the chatbot. Edit the Welcome message by altering the user's first name in automate. Next, select the 
Default Response and make the same changes. For commands that are not written into your chatbot or for any 
unanticipated errors, the default response is provided.  

We now begin adding Blocks. Blocks are the methods used in will carry out chat commands. To include these blocks, 
click the plus sign (+). The IFTTT server's APIs will be hit by these functional blocks. This Text Card can be modified to 
reflect your preferred response. Set the Relay Off with Light Off message's settings similarly. Relay On and Relay Off 
are two blocks that you should make and rename.Add a Text card to the Relay On block that you have chosen. This text 
card serves as our Chatbot's response when you complete this particular block. Now pick + ADD AI RULE from the 
menu and fill out the AI by clicking Set Up AI. This is how its AI is primarily put up. Create its AI rules by listing all 
phrases that are acceptable for a user to speak and responding with Blocks Then add the relevant block. Simply enter the 
sentence after typing it to add it. We'll stop it here. After IFTTT is configured, additional settings will be made. The 
message box from chatfuel is shown in Fig 7. 
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Fig 7. The Chatfuel Complete Setup. 
 

Setup of Adafruit IO 
Adafruit IO is the IoT end in the setup with Adafruit. Here, our ESP8266 connects to its server and issues the command 
we want. Visit Adafruit IO now. Register an account with Adafruit IO or log in.You must be sent to the Adafruit Home 
Screen after establishing Adafruit. Next, choose Feeds from the hand menu and then click Action and then Create a New 
Feed. We came up with the name "on-off," but you can call it whatever you want. Navigate to Build a New Dashboard 
under Dashboards and then go to Actions now. I gave this one the same name as well, "Light Automation". To add a new 
block, click "Blue +" in the top right corner of your Dashboard. Choose Block "Toggle". [20-28] Choose your feed and 
press "Next Step" at this time."Create the Block" after filling out the block options."Create the Block" after filling out the 
block options. The Adafruit io complete setup is shown in the following Fig8. 
 

 
 

Fig 8. The Adafruit IO Complete Setup. 
 

MQTT 
Message Queue Telemetry Transport, also known as MQTT, is a very simple communication protocol created by IBM. 
MQTT uses a publish/subscribe architecture for machine communication (M2M). MQTT is employed as a message 
transfer binding protocol in this project.Clients and brokers make up MQTT. A subscriber or publisher to or of a certain 
topic is referred to as a client. A publisher delivers value to the server, whereas a subscriber listens to the server. Adafruit 
Service is utilised as the MQTT broker and NodeMCU is the client for the prototype. The cloud platform and a 
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management dashboard are both provided by Adafruit. The terms client, subscriber, and publisher are defined during 
programming. In contrast to the sensor, relay and dc motor are subscribers that wait for external commands from the 
server (photocell)as it reads data and releases it to the server, is the publisher. 
 
IFTTT 
IFTTT is also known as “If This Then That”.IFTTT is a free web application that enables users to build applets-chains of 
straight forward conditional statements. Changes made in other web services like Gmail, Facebook, Telegram, Instagram, 
or Pinterest can start an applet. The following steps takes place in the integration of IFTTT.  

• By signing up using the same Google Account that you use for your phone, you may create an account on 
IFTTT.  

• Go to My Applets > New Applet > and then select "+ this." Look for and choose the service Webhooks. 
• Choose Request a Web Service, enter the event name, then click Create Trigger. 
• The Action Service must be filled after the Trigger has been created. Click on + that for that. Now look for and 

choose the Action Service Adafruit.  
• This will request your Adafruit Login Credentials for the first time. There, enter the information for your 

Adafruit IO account. 
• By selecting your "Feed name" and "Data to Save" as Value 1 in Add Ingredient, fill the Action form with the 

"Send data to Adafruit IO" action. Click "Create Action" then "Finish." 
• Now look for and choose the Action Service Adafruit. This will request your Adafruit Login Credentials for the 

first time. There, enter the information for your Adafruit IO account. 
• By selecting your "Feed name" and "Data to Save" as Value 1 in Add Ingredient, fill the Action form with the 

"Send data to Adafruit IO" action.  
• Click "Create Action" then "Finish." Go to My Applets (1), choose the applet you created there, and then click 

Webhooks (3).  
• We now require the JSON API URL for setup of chatfuel with IFTTT. It is accessible through Webhooks 

Settings. Hence, select Settings. Take a note of this URL and save it for later use. The IFTTT setup is shown in 
the Fig 9. 

 

 
 

Fig 9. The IFTTT Complete Setup. 
 

JSON API Link Setup 
Make two connections for light on and light off from this URL. 

For Light On, the connection is https://maker.ifttt.com/trigger//with/key//?value1=1 
For Light Off, the connection is https://maker.ifttt.com/trigger//with/key//?value1=0 
Duplicate and save these connections for Chatfuel mix. Test the connections by populating these in the Internet 

browser and checking Flip Switch made at Adafruit IO server. 
Allow us to incorporate everything now. 
Open Hand-off On and Transfer Off blocks made in Chatfuel stage. Add JSON APIs to these. Select + sign in Add a 

Card menu of Hand-off On block. Click on JSON Programming interface from Chatfuel Modules menu (Fig. 10). Select 
sort as Post and enter the connection made for Light On. Glue it in the URL Tab, as displayed in Fig10. 



 
            Advances in Intelligent Systems and Technologies 

 

169 
 

 

 
 

Fig 10. JSON API link Setup. 
 

In ths project we modify the Arduino IDE Software for programming Node MCU. Adafruit IO supports the MQTT 
protocol for device communication, often known as message queue telemetry transmission. You can publish and 
subscribe to a feed to send and receive feed data using a MQTT library or client. You will want a MQTT client library in 
order to use the MQTT API that Adafruit IO offers. The following steps are followed for the modification of the Arduino 
IDE software for programming NodeMCU: 

1. Start the Arduino IDE. Choose File > Preferences. 
2. In "Other Board Manager URLs," type http://arduino.esp8266.com/stable/package esp8266com index.json. 

Click "OK" to continue. 
3. Access Boards Manager by going to Tools > Board. 
4. Install "esp8266 by Esp8266 community" by selecting the ESP8266 board menu from the scroll-down menu. 
5. Under Tools >NodeMCU 1.0, choose your ESP8266 board (ESP12E Module). 
6. Start the Arduino IDE again. 

 
IV. DEVELOPMENT OF CODE 

In ths project we modify the Arduino IDE Software for programming Node MCU. Adafruit IO supports the MQTT 
protocol for device communication, often known as message queue telemetry transmission. You can publish and 
subscribe to a feed to send and receive feed data using a MQTT library or client. You will want a MQTT client library in 
order to use the MQTT API that Adafruit IO offers. The following steps are followed for the modification of the Arduino 
IDE software for programming NodeMCU: 

1. Start the Arduino IDE. Choose File > Preferences. 
2. In "Other Board Manager URLs," type http://arduino.esp8266.com/stable/package esp8266com index.json. 

Click "OK" to continue. 
3. Access Boards Manager by going to Tools > Board. 
4. Install "esp8266 by Esp8266 community" by selecting the ESP8266 board menu from the scroll-down menu. 
5. Under Tools >NodeMCU 1.0, choose your ESP8266 board (ESP12E Module). 

 
Code Implementation 
Programming code (facebook_chatbot.ino) is written in Arduino programming language. Prior to accumulating and 
transferring to NodeMCU board, roll out certain improvements in the code.Place your Wi-Fi accreditations as 
demonstrated inside twofold statements displayed beneath in code announcement. ESP8266WiFi.h library helps run the 
elements of Wi-Fi in Arduino IDE. 
 
#include //Adafruit MQTT Libraries 
#include // 
#include //ESP8266 Wi-Fi libraries 
#define relayPin D3 //declare the relay pin 
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#define WLAN_SSID “xxxxxxxx” //enter your 
WiFi network name within the double quotes & 
#define WLAN_PASS “xxxxxxxx” //password here 
#define AIO_SERVER “io.adafruit.com” 
#define AIO_SERVERPORT 1883 // use 8883 is used for SSL 
#define AIO_USERNAME “xxxxxxxxxx” //User name of Adafruit IO (for this click the Golden Key in Adafruit IO 
Dashboard) 
#define AIO_KEY “xxxxxxxxxx” //key of 
Adafruit IO (for this click the Golden Key in Adafruit IO Dashboard) 
Enter your feed name to subscribe to MQTT server. For more details on MQTT, visit http://mqtt.org/ 
Subscribe to MQTT. It is done in the code in Void Setup() as shown below. 
void setup() 
{ 
pinMode(relayPin, OUTPUT); 
digitalWrite(relayPin, LOW); 
Serial.begin(9600); 
delay(10); 
Serial.println(); 
Serial.println(); 
Serial.print(“Connecting to “); // 
Connect to WiFi access point. 
Serial.println(WLAN_SSID); 
WiFi.begin(WLAN_SSID, WLAN_PASS); 
while (WiFi.status() != WL_CONNECTED) 
{ 
delay(500); 
Serial.print(“.”); 
} 
Serial.println(); 
Serial.println(“WiFi connected”); 
Serial.println(“IP address: “); 
Serial.println(WiFi.localIP()); 
mqtt.subscribe(&onoffbutton); // Setup 
MQTT subscription for onoff feed. 
} 
RelayPin is set as result, which is at first low. This result is characterized in Void Circle(), as displayed below. 
void loop() 
{ 
// Ensure the connection to the MQTT server is alive (this will make the first 
// connection and automatically reconnect when disconnected). See the MQTT_connect 
// function definition further below. 
MQTT_connect(); 
// this is our ‘wait for incoming subscription packets’ busy subloop 
// try to spend your time here 
Adafruit_MQTT_Subscribe *subscription; 
while ((subscription = mqtt.readSubscrip 
tion(5000))) 
{ 
if (subscription == &onoffbutton) { 
Serial.print(F(“Got: “)); 
Serial.println((char *)onoffbutton. 
lastread); 
String response = (char*)onoffbutton. 
lastread; //converts the received 1 
or 0 to string to compare in the if- 
else statement 
if (response == “1”) 
{ 
digitalWrite(relayPin, HIGH); 
} 
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else 
{ 
digitalWrite(relayPin, LOW); 
} 
} 
} 
} 
 

Save the code and transfer it through USB link. Remember to choose the COM port from Apparatuses menu in 
Arduino IDE prior to transferring the code. 
 

V. RESULT ANALYSIS 
At First when we open the messenger application and type the message “Turn on the light” or “Switch on the light” and 
send the message and when the message is delivered it sends the value 1 to the JSON API link which we generated by 
the IFTTT(IF this then That) platform, Then it triggers the Event Name “Light” and the value 1 is sent  to the Adafruit IO 
platform where we created a “Dashboard”  with the Name “On/Off Switch Block”. Then it is sent the value 1 to the 
NodeMCU in which we have already stored the Adafruit name and Key in the Program and it subscribes to the MQTT 
server.The AI Chatbot is connected to an MQTT broker, which acts as a message hub for all connected devices and 
clients. Each appliance that the Chatbot can control is also connected to the MQTT broker as a client, and subscribes to a 
specific topic on the broker. The user interacts with the Chatbot through a chat interface, and requests that the Chatbot 
perform a certain action (e.g. turn on the lights). The Chatbot receives the user's request, and publishes a message to the 
MQTT broker on the appropriate topic (e.g. "lights/on"). The appliance that subscribes to the "lights/on" topic receives 
the message, and performs the requested action (i.e. turns on the lights). The appliance can also send messages back to 
the Chatbot through the MQTT broker, for example to report its status (e.g. "lights are now on"). When the NodeMCU 
connects with the WiFi of which the details are already stored in the Code of the NodeMCU. Then the signal from the 
pin D3 is sent to the relay module input pin whereas relay module is an electro-mechanical switching device. In a relay, 
we can control switching AC or DC appliances digitally by providing input to relay input pins. Here we have used a 1-
channel relay operating on 5 Volts. Then relay module provides the electricity to the appliance to be controlled. When 
the value is 1 the power is directly supplied  to the Circuit as shown in the Fig 11. When the value is 0 the power is 
directly cut of from the Circuit as shown in the Fig 12. 
 

 
 

Fig 11. Power Supply into Circuit. 

 
 

Fig 12. Poweroff into theCircuit. 
 

VI. CONCLUSION 
In conclusion, an artificial intelligence-based chatbot for appliance control can be a highly beneficial and convenient 
solution for home automation. With the use of natural language processing and machine learning algorithms, the chatbot 
can interpret user commands and control various appliances in the home, such as lights, thermostats, and smart devices. 
This type of chatbot can provide users with a more streamlined and intuitive way of interacting with their home 
appliances, eliminating the need for complex user interfaces and multiple apps. Additionally, with the ability to learn 
from user behavior and preferences, the chatbot can offer personalized recommendations and suggestions for optimizing 
energy usage and improving overall home comfort. While there may be some challenges in terms of accuracy and 
security, these can be addressed with careful design and development. Overall, an artificial intelligence-based chatbot for 
appliance control has the potential to revolutionize the way we interact with our homes, making them more efficient, 
convenient, and comfortable. The system suggested in this paper is a clever way to incorporate electrical appliances into 
daily life.  
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The study suggests employing AI in conjunction with IoT, but it also demonstrates a strategy for the emerging Social 
Internet of Things (SIoT), where social networking principles can be combined with IoT to allow for the direct 
integration of a physical device into a social platform. The resulting paradigm may enable cutting-edge networking 
services and IoT applications in more effective, efficient, and secure ways. The formation and administration of social 
interactions between things can be facilitated by technology in a way that makes the resulting social network navigable in 
the same way that people connect on social media. The report also outlines a potential IoT architecture that has the 
features needed to incorporate items into social networks.The formation and administration of social interactions between 
things can be facilitated by technology in a way that makes the resulting social network navigable in the same way that 
people connect on social media. The report also outlines a potential IoT architecture that has the features needed to 
incorporate items into social networks. The outcome (chatbot) of this project is is shown in the Figure given below. This 
project is made using C++ programming language and the softwares like Chatfuel, Adafruit IO, IFTTT (If This Than 
That), and hardwares like NodeMCU and Relay Module has been used. The Completed output of the chatbot is shown in 
the Fig13 
 

 
 

Fig 13. The Chatbot for Appliance Control. 
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